July 26th, 2020

Жопорукие рукожопы

Ну что же, писатели софта под линух в очередной раз подтвердили свою рукожопость, не так, так эдак....

tyx

Всем, кто сталкивался, известна проблема линуха - под него трудно найти офисный пакет, корректно интерпретирующий сложноформатированные документы Ворд и таблицы Эксел. Если у вас происходит обмен со смежниками или внутри конторы не в PDF - это проблема. Все столь любимые детишками LibreOffice и прочие xxxOffce имеют один существенный недостаток - стоит в них скормить сложно форматированный документ Ворд в формате doс или docx, с рамками, формулами, сложными таблицами - содержимое обычно едет, тексты меняют форматирование, рамки корёжит, формулы не обсчитываются. Последним кандидатом на то, чтобы использоваться в работе и стать возможной заменой MS был WPS-office - он правильно транслировал вордовские файлы и даже позволял редактировать формулы в полях, которые редактор потом интерпретировал, прям как настоящий word (популярный libre office этого не умеет, например). Но и он подсунул подляну. Понадобилось тут мне проверить на совместимость и корректное отображение последнюю версию (у заказчиков условие - корректное отображение текстовых форматов документации под линухом в редактируемом формате), поставил я под 10й виндой виндовый дистрибутив и сюрприз - он мне убил виндовый Эксель, снеся какую-то библиотеку и покорёжив реестр. ;-)

То, что сам пакет кривой и забирает под себя все контекстные меню через собственный лаунчер, относящиеся к документам, а сама система запуска документов в нём сделана через жопу - как бы пол-беды, я не собирался им пользоваться. Но деинсталлятор можно было нормально сделать? Чтобы он не оставлял после себя в качестве строки ассоциации для doc "AppData\Local\Kingsoft \WPS 0ffice\11.2.0.9453\office6\wps.exe" / prometheus /wps "%1" - это ещё полбеды, можно вручную прописать.

Проблема не решилась даже полной переустановкой программного пакета с восстановлением реестра из бэкапной ветки - придётся восстановить всю систему с 0 из майского бэкапа - эксель 2010 теперь каждый раз при запуске пишет о нехватке какой-то библиотеки и запускает инсталлятор...

Кто-то скажет, что под линухом такая ситуация в принципе невозможна... Наверное да... Ну так под виндой такую ситуацию создают обычно крайне кривые программы, это тоже медицинский факт ;-)

В общем, моё мнение о линуксах пока прежнее - только для использования в гомогенной среде, где он стоит на всех компах, либо в качестве развлечения для детишек, дрочащих на пингвина, которым больше нечем заняться, кроме копания в манах и исходниках...